Project

General

Profile

Emulator Issues #9842

Dolphin doesn't autodetect the 16:9 aspect ratio in NFS: Most Wanted (USA)

Added by darkrocket over 4 years ago. Updated 6 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Need for Speed: Most Wanted (USA)

Game ID? (right click the game in the game list, properties, info tab)

GOWE69

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

ccae1994b8ab098ff427e6ef95ea7909

What's the problem? Describe what went wrong.

The Dolphin aspect ratio stays 4:3 when you activate the widescreen mode in the game.

What steps will reproduce the problem?

Start the game, go to Options -> Video and set the widescreen mode on.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

5.0-971.
4.0-7138 (first version that included aspect ratio detection).

In none of them does it work properly.

What are your PC specifications? (CPU, GPU, Operating System, more)

i7-6700HQ, GTX 960M, Windows 10.

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

aspectratio.7z (1.39 MB) aspectratio.7z darkrocket, 10/12/2016 12:03 PM

Related issues

Is duplicate of Emulator - Emulator Issues #12254: Widescreen Heuristic Mega-IssueAccepted

History

#1 Updated by JMC4789 over 4 years ago

There are some games that can't be detected due to how they do Widescreen (they don't change the viewport or whatever that the heuristic uses.)

We can have someone look into it, but there's not much hope for it unless they can find a way to detect it.

Maybe a fifolog of the game switching from 4:3 to 16:9 would help in that regard.

#2 Updated by darkrocket over 4 years ago

I have recorded a 10 frame fifolog changing the aspect ratio from 4:3 to 16:9.

#3 Updated by JMC4789 6 months ago

  • Status changed from New to Duplicate

Compiling all of these into a single issue. Thank you for your report.

#4 Updated by JMC4789 6 months ago

Also available in: Atom PDF