Project

General

Profile

Emulator Issues #9873

VertexShaderGen.cpp assertions occasionally fail when loading back savestates

Added by dragonbane over 4 years ago. Updated 14 days ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

GC Twilight Princess NTSC (likely doesnt matter)

Game ID? (right click the game in the game list, properties, info tab)

GZ2E01

What's the problem? Describe what went wrong.

Occasionally when loading back savestates, this error pops up:

http://image.prntscr.com/image/4b01b80459bf44bd9a682a90981e9d6e.png

Followed by the same message except its about Line 25

What steps will reproduce the problem?

Launch Game
Save a state
Spam reload until you get the error

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

Error occurs on 5.0-1223 (dual core disabled, D3D 11)

What are your PC specifications? (CPU, GPU, Operating System, more)

Windows 7 x64 SP1
Intel i5
AMD HD 7970


Related issues

Is duplicate of Emulator - Emulator Issues #9930: SSX Tricky: Assertion failure in VertexShaderGen.cpp: bpmem numtexgens doesn't equal xfmem numtexgensFixed

History

#1 Updated by ligfx about 4 years ago

#2 Updated by Miksel12 10 months ago

This assertion has been fixed by 5.0-11866.

#3 Updated by JosJuice 14 days ago

  • Is duplicate of Emulator Issues #9930: SSX Tricky: Assertion failure in VertexShaderGen.cpp: bpmem numtexgens doesn't equal xfmem numtexgens added

#4 Updated by JosJuice 14 days ago

  • Status changed from New to Duplicate

Also available in: Atom PDF