Project

General

Profile

Emulator Issues #9878

Vulkan backend - Real XFB doesn't work (black screen)

Added by markwest76 almost 4 years ago. Updated over 3 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Every game

Game ID? (right click the game in the game list, properties, info tab)

-

What's the problem? Describe what went wrong.

Dolphin 5.0-1241 should have implemented XFB for the Vulkan backend, but only the virtual one works, real XFB still shows a black screen

What steps will reproduce the problem?

Load a game that forces Realk XFB in game ini or enable real XFB in video config, then start a game and see the screen completely black (although in the background the game is still running since you can hear game audio)

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

Tested on Dolphin 5.0-1259

What are your PC specifications? (CPU, GPU, Operating System, more)

Windows 10 64 bit - Intel e8600 - Geforce Gtx950 (Driver 375.70)

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

With Batman Vengeance if you wait some time without doing anything, you can see the in-game demo running, but everything (sprites and backround) are filtered to purple color

Dolphin_config_files.rar (9.62 KB) Dolphin_config_files.rar markwest76, 11/07/2016 04:26 PM

History

#1 Updated by JMC4789 almost 4 years ago

It works for me on my GTX 1070, We need to narrow down what hardware it happens on.

#2 Updated by FireNX70 almost 4 years ago

It's working on my GTX 980 with 375.70 drivers, so it's not a problem with the 9XX Series

#3 Updated by Stenzek almost 4 years ago

Could you please attach your config files (Dolphin Emulator\Config) to this report?

#4 Updated by seapancake almost 4 years ago

Able to replicate on 5.0-1259 with 372.90 drivers, upgraded to 375.70 and able to get up to the N64 logo for Majora's mask however never gets to title screen.

#5 Updated by JMC4789 almost 4 years ago

If you're on Majora's Mask on VC that's normal.

#6 Updated by markwest76 almost 4 years ago

Here's my config files

Speaking of Nvidia Drivers, I usually make a fresh install of only the Drivers and avoid to install audio hd, 3dVision, Experience and other stuff...so might be that I'm missing something? (I don't think so, but you never know :-) )

#7 Updated by Stenzek over 3 years ago

Can you please try with this PR and see if it makes any difference? https://github.com/dolphin-emu/dolphin/pull/4462

If you need a prebuilt version: https://dl.dolphin-emu.org/prs/pr-4462-dolphin-latest-x64.7z

#8 Updated by JMC4789 over 3 years ago

  • Status changed from New to Invalid

This was a NVIDIA driver issue. Majora's Mask (VC) doesn't work in Dolphin yet.

#9 Updated by markwest76 over 3 years ago

No, with that PR it still doesn't work (tried Batman Vengeance with Drivers 375.70 and 375.95 both show only a black screen)

#10 Updated by Stenzek over 3 years ago

I tried RealXFB using your config files on my system (driver 375.70, although not with this game) and it was fine.

Given it works for other people on Maxwell 2 I'm not sure what the common factor is here. Does RealXFB work with other games?

#11 Updated by markwest76 over 3 years ago

No, if I enable realXFB I get a black screen with every game (this happens only with the Vulkan backend, other backends are fine)

#12 Updated by Stenzek over 3 years ago

Could you pull/download the PR and try again? Would like to test a theory as I found a bug elsewhere that may be related.

#13 Updated by markwest76 over 3 years ago

I downloaded the PR again from the link above, but the revision code (3d21....c91) is the same as the previous one, so are you sure it has been updated? If yes, it stil doesn't work.

#14 Updated by Stenzek over 3 years ago

The index will be the same due to how our buildbots apply/compile pull requests, this is expected.

I'm really not sure what's going on here. I borrowed a GTX950 to test with and it seems fine to me both before and after PR4462. Only difference is the system I tested on had a 4770K, but I doubt this would be the cause.

#15 Updated by markwest76 over 3 years ago

I don't think it's a gtx950 only problem: if you see the comments on the original PR, Tinob has realXFB black screen either using gtx750, amd r9 290 or amd rx480...so the problem must be elsewhere

Also available in: Atom PDF