Project

General

Profile

Emulator Issues #9880

D3D11 Black Screen on Every Game

Added by iwubcode almost 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Every game

What's the problem? Describe what went wrong.

Running a game using the D3D11 backend causes the system to hang on a black screen. Alt-tabbing, then clicking on the black screen causes dolphin to crash.

What steps will reproduce the problem?

Pick D3D11, choose a game, see black screen.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

Dolphin 5.0-1245

Note: Dolphin 5.0 will work

What are your PC specifications? (CPU, GPU, Operating System, more)

i7 6700k
rx480 reference (AMD driver 16.11.2)
Win 10
16gb ram

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

Running at 4k native, 16x Antriscopic filtering, vsync, fullscreen, per-pixel lighting, scaled efb-copy, 24bit color... none of these settings seem to matter though.


Related issues

Is duplicate of Emulator - Emulator Issues #9723: Dolphin hanging forever when launching any Wii games in full screen + DX11Fixed

History

#1 Updated by seapancake almost 4 years ago

Does Dolphin 5.0-1241 work? Also have you tried disabling XFB in 1245? It's possibly fallout from implementation of XFB in Vulkan is affecting other backends.

#2 Updated by Stenzek almost 4 years ago

I haven't noticed such an issue on my AMD system (GCN2), so perhaps this limited to Polaris.

Bisecting this to a version or a range of versions would definitely be helpful.

The changes made for XFB support in the Vulkan backend did not change anything in VideoCommon or the D3D backend, so this is unrelated.

#3 Updated by Disorderly almost 4 years ago

I'm getting a different (but possibly related) issue with my 7770 with Use Fullscreen enabled. When I press Alt+Enter to go out of fullscreen, the game will not switch to windowed mode. Instead, it will stay in fullscreen mode, but only the top-left of the image will be left on-screen.

#4 Updated by JosJuice almost 4 years ago

Have you tested that this happens with both GameCube and Wii games? (Just checking if this is the well-known 5.0-76 regression)

#5 Updated by iwubcode almost 4 years ago

JosJuice wrote:

Have you tested that this happens with both GameCube and Wii games? (Just checking if this is the well-known 5.0-76 regression)

I'll test that now, but here's what I tried:

  • Dolphin 383 (d3d11 didn't work)
  • Dolphin 103 (d3d11 didn't work)
  • Dolphin 76 (d3d11 didn't work)
  • Dolphin 72 (d3d11 DID work)

So it looks like you're right, it's a regression caused by 76. My apologies, I didn't know if this was a well known issue.

#6 Updated by JosJuice almost 4 years ago

  • Status changed from New to Duplicate

No worries.

#7 Updated by JosJuice almost 4 years ago

  • Is duplicate of Emulator Issues #9723: Dolphin hanging forever when launching any Wii games in full screen + DX11 added

Also available in: Atom PDF