Project

General

Profile

Emulator Issues #9913

JitArm64 regression in 5.0-540 - Back to the Future shows panic alert

Added by Weky about 3 years ago. Updated about 1 year ago.

Status:
Invalid
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

[Back to the future]

Game ID? (right click the game in the game list, properties, info tab)

[Put Game ID here]

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

[Put MD5 Hash here]

What's the problem? Describe what went wrong.

[Game run just fine on dolphin 5.0-9 jit 64 butt no wii emulated controllers on this version]

What steps will reproduce the problem?

[ 5.0-1351dolphin Cached interpreter wii game to slow on this,jit 64 recompiler panic alert, 5.0-9 its run on jit 64]

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

[5.0-9
5.0-1351]

What are your PC specifications? (CPU, GPU, Operating System, more)

[PC specs here]

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

[Anything else here]


Related issues

Has duplicate Emulator - Emulator Issues #9912: Android - JIT ARM64 RegressionsDuplicate

Has duplicate Emulator - Emulator Issues #9980: Android revision on 5.0 -540Duplicate

History

#1 Updated by degasus about 3 years ago

  • Status changed from New to Questionable
  • Assignee set to degasus

Which message has the PanicAlert?

Which revision broke it exactly? There are a lot of commits between 5.0-1351 and 5.0-9. But it may be fine that the full PanicAlert message be enough.

Please provide more informations.

#2 Updated by Weky about 3 years ago

5.0-532 is still good jit64 butt revision 5.0-542 is broken revision-panic alert on jit 64 android,game back to the future

#3 Updated by JosJuice about 3 years ago

#4 Updated by degasus about 3 years ago

There is no 5.0-542.

#5 Updated by Weky about 3 years ago

5.0-540 revision is brooken jit 64 android game back to the future

#6 Updated by JosJuice about 3 years ago

  • Subject changed from Android arm64 to JitArm64 regression in 5.0-540 - Back to the Future shows panic alert

#7 Updated by degasus about 3 years ago

  • Subject changed from JitArm64 regression in 5.0-540 - Back to the Future shows panic alert to Android arm64

Do you get any additional error message? Or just the "Dolphin has stopped working"?

#8 Updated by degasus about 3 years ago

  • Subject changed from Android arm64 to JitArm64 regression in 5.0-540

#9 Updated by degasus about 3 years ago

  • Subject changed from JitArm64 regression in 5.0-540 to JitArm64 regression in 5.0-540 - Back to the Future shows panic alert

#10 Updated by Weky about 3 years ago

Panic alert invaild write to 0x00000000,pc =0x8001eed0 50331648 revision dolphin 5.0-540 dolphin stop working on jit64

#11 Updated by JosJuice about 3 years ago

#12 Updated by degasus about 1 year ago

Might you try this issue again with a more recent version of dolphin? We've fixed some JitArm64 issues, so this issue might be resolved already.

#13 Updated by JMC4789 about 1 year ago

  • Status changed from Questionable to Invalid

I was going to verify this but because there's no game ID I'm not sure exactly what game is being talked about.

I don't know why I kept it open to begin with.

Also available in: Atom PDF