Project

General

Profile

Emulator Issues #9922

[D3D12]Baldur's Gate: Dark Alliance has texture corruption on certain objects in D3D12

Added by mstreurman almost 3 years ago. Updated over 2 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
Windows
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Baldur's Gate: Dark Alliance NTSC-U

Game ID? (right click the game in the game list, properties, info tab)

GDEE71

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

3b428c5f5e7f60d1dac28a792d5c0367

What's the problem? Describe what went wrong.

D3D12 has flashing texture corruption on certain objects.

What steps will reproduce the problem?

load my savestate (or use my memory card, load the 1st save and walk up against the wall of boxes)

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

5.0-1395

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel Core i7 4800MQ, nVidia GeForce GTX870m 6GB, 16GB Ram, Windows 10 x64 Anniversary Edition

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

With the graphics configuration screen and the game open I changed all options one by one to see if anything changes: If I turn on XFB (Virtual or Real makes no difference) the flashing of the distortion slows down (might be because it of course is more demanding, but I thought I'd mention it anyway) and sometimes the object is visibile without corruption.

OpenGL and D3D11 do NOT have this issue. Vulkan has a different issue which I will make a different bugreport for.

All of the other graphics options change nothing, also changing from dual-core to single-core doesn't change anything.

Added screenshot and log and savegame, uploaded FIFOLOG and Savestate to MEGA because of size.
FIFOLOG: https://mega.nz/#!wtgzgbxB!u_3uOlZuXD2x9qFH4ADUaoFFZtuzWzho1__SAVFlC7g
SAVESTATE: https://mega.nz/#!sgZU3LSB!MpXyG_EL-4D9T6MBejtfF1cKfvV8KScYm44ufRixvho

BGDA D3D12 Log.txt (2.37 KB) BGDA D3D12 Log.txt Log which logs everything on Warning mstreurman, 11/30/2016 10:28 AM
GDEE71-1.png (346 KB) GDEE71-1.png Screenshot of the issue mstreurman, 11/30/2016 10:32 AM
71-GDEE-BGDA_slot00-1130-104429-133.gci (232 KB) 71-GDEE-BGDA_slot00-1130-104429-133.gci Savegame Baldur's Gate Dark Alliance, just walk up to the boxes from here mstreurman, 11/30/2016 10:47 AM
5727

History

#1 Updated by mstreurman almost 3 years ago

When this happens emulation speed goes from a consistent 100% (62-63FPS) to about 50% (30-32FPS)

#2 Updated by Helios over 2 years ago

  • Status changed from New to Won't fix
  • Operating system Windows added
  • Operating system deleted (N/A)

Won't be fixed anymore. D3D12 has been removed from master as of https://dolphin-emu.org/download/dev/1880a97bb055b917108b1391d44fa9c04015c289/ and is no longer supported.

Also available in: Atom PDF