Project

General

Profile

Emulator Issues #9936

Black Stripes on water - RE4

Added by lmello over 3 years ago. Updated about 2 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Resident Evil 4 - Wii Edition

Game ID? (right click the game in the game list, properties, info tab)

RB4E08

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

6a8e2bd9a873cf5c168d718ae33a0bbd

What's the problem? Describe what went wrong.

Water textures (except on the lagoon) present black bars

What steps will reproduce the problem?

See screenshots below.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

5.0

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel Core i5 4690 @ 3.5Ghz x 4 (turbo boost enabled - up to 3.90Ghz)

Radeon R7 250E

Manjaro Linux, kernel 4.8.9, mesa 13.0.1

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

Skip EFB Access from CPU enable for speedup @ HD

RB4E08-3.png (2.1 MB) RB4E08-3.png lmello, 12/05/2016 06:32 AM
RB4E08-2.png (2.06 MB) RB4E08-2.png lmello, 12/05/2016 06:32 AM
RB4E08-3.png (2.1 MB) RB4E08-3.png lmello, 12/05/2016 07:00 AM
RB4E08-2.png (2.06 MB) RB4E08-2.png lmello, 12/05/2016 07:00 AM
data.bin (462 KB) data.bin export save file lmello, 12/07/2016 12:33 AM
RB4E08-2.png (2.36 MB) RB4E08-2.png Chapter 3-1, waterfall lmello, 12/07/2016 12:33 AM
RB4E08-7.png (2.37 MB) RB4E08-7.png Final Chapter water, before access to the inventory screen lmello, 12/07/2016 12:38 AM
RB4E08-8.png (2.29 MB) RB4E08-8.png Final Chapter water, after access to the inventory screen lmello, 12/07/2016 12:38 AM
RB4E08-1.png (2.59 MB) RB4E08-1.png How the water is supposed to look like lmello, 12/07/2016 03:04 AM
RB4E08-2.png (2.57 MB) RB4E08-2.png How the water glitches out after accessing the inventory screen lmello, 12/07/2016 03:05 AM
RB4E08-6.png (2 MB) RB4E08-6.png correct rendering lmello, 12/08/2016 06:58 AM
RB4E08-7.png (1.74 MB) RB4E08-7.png open the inventory to reproduce the bug lmello, 12/08/2016 06:58 AM
RB4E08-8.png (2.01 MB) RB4E08-8.png glitched water textures lmello, 12/08/2016 06:58 AM
glinfo.txt (6.29 KB) glinfo.txt glinfo > glinfo.txt lmello, 12/08/2016 07:01 AM
glxinfo.txt (101 KB) glxinfo.txt glxingo > glxinfo.txt lmello, 12/08/2016 07:01 AM
RB4E08-9.png (3.23 MB) RB4E08-9.png Salazar (chapter 4-4 boss) also affected lmello, 12/08/2016 10:05 PM
5735
5736
5737
5738
5750
5751
5752
5753
5754
5757
5758
5759
5762

History

#1 Updated by lmello over 3 years ago

5737
5738

Game Name?

Resident Evil 4 - Wii Edition

Game ID? (right click the game in the game list, properties, info tab)

RB4E08

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

6a8e2bd9a873cf5c168d718ae33a0bbd

What's the problem? Describe what went wrong.

Water textures (except on the lagoon) present black bars

What steps will reproduce the problem?

Savestate, die and continue from a checkpoint

See screenshots below.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

5.0

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel Core i5 4690 @ 3.5Ghz x 4 (turbo boost enabled - up to 3.90Ghz)

Radeon R7 250E

Manjaro Linux, kernel 4.8.9, mesa 13.0.1

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

Skip EFB Access from CPU increases performance @ HD resolutions

The wiki says:


PerfCounters

This game uses a feature known as PerfCounters. Using emulator features such as savestates can cause this feature to glitch out, making the game run incredibly slow. There is no known solution to this quirk. Restarting the game after a normal save will remedy the slowdown.


Slowdown doesn't happen anymore, but this water glitch still happens

#2 Updated by lmello over 3 years ago

Actually, to reproduce this problem all that you have to do is to use a rifle, then the black bars appear.

#3 Updated by lmello over 3 years ago

No, not even that. All you have to do is to go to the inventory screen.

#4 Updated by JMC4789 over 3 years ago

Is this only on the Wii version?

I only have savefiles far enough on the GC version; you'd need to export your save for me.

#5 Updated by lmello over 3 years ago

5750
5751
5752

Is this only on the Wii version?

AFAIC, only.

I noticed something not right on chapter 3-1 in the waterfalls. The black stripes only appear on non-transparent water textures.

I ended up finishing the game, but I imported a save file on gamefaqs and played a little bit. You can see same issue on the Final Chapter.

I exported the save file, on slot 18 you are at chapter 3-1 and on slot 1 you are on the final chapter: run from Saddler and you can see the before / after bars on the water below the platform.

#6 Updated by lmello over 3 years ago

5753
5754

Actually, no save needed in order to replicate the bug: in the very beginning of the game you can verify this. After the first typewriter, you'll soon cross a bridge over a small river. Save, reboot, load the game and go all the way to the bridge. As soon as the inventory screen is accessed the water textures glitches out, with the stripes.

#7 Updated by lmello over 3 years ago

5757
5758
5759

More information and a personal save file on 4-1 right after you fall in the pit. Climb the ladder and you'll see the type of water texture. If you open your inventory even once the water glitches; only resetting the game the textures are properly rendered again.

Here's my glinfo and glxinfo output, as well as some screenshots.

#8 Updated by Helios over 3 years ago

Have you tried this on the latest development release?

#9 Updated by lmello over 3 years ago

5762

Yes, as of 5.0-1446 this happens.

Salazar looks weird too.

#10 Updated by JMC4789 over 3 years ago

  • Status changed from New to Questionable

It appears to be a game bug drawn out by running the game at higher resolutions.

You can try turning off "Scaled EFB Copies" if you want. If that doesn't fix it, you'll have to run it at 1x IR in order to avoid the bugs.

#11 Updated by lmello over 3 years ago

It appears to be a game bug drawn out by running the game at higher resolutions.

You can try turning off "Scaled EFB Copies" if you want. If that doesn't fix it, you'll have to run it at 1x IR in order to avoid the bugs.

Nailed it.

Using fixed IR solves the problem, wheter "Scaled EFB Copies" is set or not.

I was using "Auto" resolution settings.

#12 Updated by mimimi over 3 years ago

Nailed it.

Using fixed IR solves the problem, wheter "Scaled EFB Copies" is set or not.

I was using "Auto" resolution settings.

Which of the 2 auto settings did you use? If it was window size, i really want to remove that option.

#13 Updated by JMC4789 over 3 years ago

Why is auto-IR changing the resolution at times... That's not a good thing.

#14 Updated by lmello over 3 years ago

Which of the 2 auto settings did you use? If it was window size, i really want to remove that option.

Both Auto settings trigger the glitch in this game.

#15 Updated by JMC4789 over 3 years ago

Yep; when switching menus it's changing resolutions lol. AutoIR is weird.

#16 Updated by lmello over 3 years ago

JMC4789 wrote:

Yep; when switching menus it's changing resolutions lol. AutoIR is weird.

The game itself changes the resolution... you can see it by enabling "Auto adjust Window Size" with Auto IR. I added some information on the wiki about this.

#17 Updated by lmello about 3 years ago

I'd like to request a closure since I found out quick fixes to render the water properly:

  • With OpenGL set a fixed IR
  • With Vulkan disable "Fast Depth Calculation"

#18 Updated by JMC4789 about 2 years ago

  • Status changed from Questionable to Invalid

Closing the issue as requested. JUST a tad late.

Also available in: Atom PDF