Project

General

Profile

Emulator Issues #9940

House of the Dead Overkill crash on Vulkan and unusable on OpenGL

Added by gourdcaptain about 3 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

House of the Dead: OVERKILL

Game ID? (right click the game in the game list, properties, info tab)

RHOE8P

What's the problem? Describe what went wrong.

The game runs fine until you attempt to start a story mode game. Then either on OpenGL, the graphics undergo intense warping to the point of it being impossible to make out what should be going on a few seconds into the intro. On Vulkan, the opening Nintendo screen is rendered only as faint outlines, and the game crashes shortly after starting Story mode with a Segmentation Fault (dmesg indicates it occured in the Vulkan drivers).

What steps will reproduce the problem?
Run House of the Dead OVERKILL in either OpenGL or Vulkan graphics. Start Story mode.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

5.0r1444

What are your PC specifications? (CPU, GPU, Operating System, more)
Arch Linux 64-bit
Intel Core i7 6800k
AMD Radeon RX 460 (4 GB) using Mesa 13.0.2 graphics drivers.

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

Attached logs and screenshots. Turned on the logging options that sounded related to video in Vulkan, feel free to ask if you want others. Logged the output in the terminal with logging turned on to capture any extra messages from the driver. Unfortunately could not get the rather spectacular full terminal messages generated on Vulkan on the first try, but I did get the ending bit of
"amdgpu: Failed to created the BO list for submission
vk: error: failed to submit CS 0"
repeating enough to flood the terminal buffer preventing me from seeing the rest.

RHOE8P-1.png (173 KB) RHOE8P-1.png OpenGL Warping 1 gourdcaptain, 12/07/2016 12:01 AM
RHOE8P-2.png (78.3 KB) RHOE8P-2.png OpenGL Warping 2 gourdcaptain, 12/07/2016 12:01 AM
RHOE8P-3.png (142 KB) RHOE8P-3.png OpenGL Warping 3 gourdcaptain, 12/07/2016 12:01 AM
RHOE8P-4.png (173 KB) RHOE8P-4.png OpenGL Warping 4 gourdcaptain, 12/07/2016 12:01 AM
RHOE8P-5.png (51.7 KB) RHOE8P-5.png Vulkan Nintendo Splash (inverted colors, outline) gourdcaptain, 12/07/2016 12:01 AM
dolphin-stderr-log-opengl.txt (623 Bytes) dolphin-stderr-log-opengl.txt Dolphin Log (OpenGL) gourdcaptain, 12/07/2016 12:01 AM
dolphin-stderr-log-vulkan.txt (7.05 KB) dolphin-stderr-log-vulkan.txt Dolphin Log (Vulkan) gourdcaptain, 12/07/2016 12:03 AM
RHOE8P-6.png (59.9 KB) RHOE8P-6.png Visual glitch on 5.0r1444 with software renderer. gourdcaptain, 12/07/2016 11:08 PM
5739
5740
5741
5742
5743
5756

Related issues

Has duplicate Emulator - Emulator Issues #9948: House of the Dead: Overkill - Dual Core graphical issues.Duplicate

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by gourdcaptain about 3 years ago

5756

Occurs (but to a lesser degree) on the same system with Dolphin 5.0 stable. Trying it with the software renderer causes a hilariously large audio-video desynch followed by an extreme version of the bug on Software on 5.0. There's a less extreme desynch on 5.0r1444 (still pretty remarkable) with Software, and the same visual glitch then kicks in and the sound then goes into a loop repeating the same two seconds over and over again and stops entirely.

#2 Updated by JMC4789 about 3 years ago

I'm worried that this is some kind of driver bug or something but I don't have this particular game to test. The fact it happens on the SW renderer is interesting, but, if you're running on dualcore that is really moot unfortunately.

#3 Updated by gourdcaptain about 3 years ago

Does not appear to happen in Single Core in any renderer other than Vulkan. Well, there goes my chances of ever playing this game in Dolphin. (Current processor is great at parallel workloads (I got it for video rendering) but not especially great single-core.)

#4 Updated by gourdcaptain about 3 years ago

Actually, after thinking of them, I tried GPU Sync Thread and Fake Completion Dual-Core. Both work in fixing the issue on OpenGL (Vulkan is still broken), although GPU Sync Thread murders performance. Fake Completion's pretty useable though. :)

#5 Updated by JosJuice about 3 years ago

#6 Updated by orbea about 3 years ago

As show in the duplicate issue and the screenshot's in this issue I am also experiencing problems with OpenGL (I don't have access to vulkan currently). For me turning off dual boot resolves the graphical issues, but also makes it too slow to play.

Apitrace: http://ks392457.kimsufi.com/orbea/stuff/trace/dolphin-emu-hotd-overkill.trace.xz

#7 Updated by orbea about 3 years ago

Could this potentially be something that only occurs with mesa? Reportedly it does not occur with windows.

#8 Updated by gourdcaptain about 3 years ago

As I noted above, this occurs in the Software Renderer in Dual-Core, so it shouldn't be a Mesa problem, right?

#9 Updated by orbea about 3 years ago

One more thing I noticed was that this game has certain short lived sections where the its slower, from 25 fps (Full speed) to ~18 - 20 fps, these sections directly correspond with the graphical issues with OpenGL and dual core wbere the fps will also drop while still seeming full speed. So the speed up noticed with dual core may be somewhat misleading?

#10 Updated by JMC4789 over 1 year ago

  • Status changed from New to Duplicate

#11 Updated by JMC4789 over 1 year ago

Also available in: Atom PDF