Project

General

Profile

Emulator Issues #9947

Real Wiimote connection problems with Toshiba bluetooth stack

Added by terence4444 over 3 years ago. Updated 3 months ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Current
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
5.0-876
Fixed in:

Description

Game Name?

Just Dance 2017

Game ID? (right click the game in the game list, properties, info tab)

SZ7P41

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

c52fd7eba956b570139f02df1c642787

What's the problem? Describe what went wrong.

Changing controller configuration while running a game causes real Wiimote disconnected.

What steps will reproduce the problem?

  1. Connect Wiimote to PC (Paired but four LEDs blink)
  2. Start Dolphin -> Open Controller Settings -> Wii Remote 1-> Real Wii Remote -> Refresh (Now only 1 LED is on but it says: A support Bluetooth device could not be found so you must connect Wii Remotes manually)
  3. Run any game (in my case it's Just Dance 2017). The real Wii Remote works fine.
  4. Since I don't have a sensor bar, sometimes I have to switch to Emulated Wii Remote to get pass through some Menus.
  5. But after that I want to switch back to the real Wii Remote (without Nunchuk), it doesn't work. The yellow message on the game screen is always "Wii Remote is disconnected". Clicking Refresh Button does not work. The Real Wii Remote does not work unless close and restart Dolphin.
  6. I have tried Version 5.0, there is no such problem (Just Dance 2017 is not supported). But the new builds (5.0-546/5.0-1444 with controller settings interface changed) have this problem.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

Version with problem: 5.0-546 and 5.0-1444
Older Version without problem: 5.0

What are your PC specifications? (CPU, GPU, Operating System, more)

PC Hardware: i7-4790K/AMD 280X/16GB RAM/A general Bluetooth adapter
Wii Remote: RVL-CNT-01 (without Nunchuk)
Windows 10 X64
Bluetooth Driver: Toshiba Stack v9.10.32(T)

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

---------------When I Start Game --------------------------------------
58:15:799 Main.cpp:496 N[Wiimote]: Not connected
58:17:327 HW\WiimoteReal\WiimoteReal.cpp:459 N[Wiimote]: Resuming Wiimote data reporting.
58:17:989 Main.cpp:496 N[Wiimote]: Connecting...
58:18:039 Main.cpp:496 N[Wiimote]: Wii Remote Connected
---------------When I changs Wiimote to Emulated Wii Remote when the game is running ----------------
59:05:844 Main.cpp:496 N[Wiimote]: Connecting...
59:05:869 Main.cpp:496 N[Wiimote]: Wii Remote Connected
---------------When I changes Wiimote to Real Wii Remote when the game is running -----------------------
59:14:592 HW\WiimoteReal\IOWin.cpp:708 W[Wiimote]: IOWrite[WWM_WRITE_FILE]: Error on WriteFile: 00000001
59:14:592 HW\WiimoteReal\IOWin.cpp:708 W[Wiimote]: IOWrite[WWM_WRITE_FILE]: Error on WriteFile: 00000001
59:14:593 HW\WiimoteReal\IOWin.cpp:708 W[Wiimote]: IOWrite[WWM_WRITE_FILE]: Error on WriteFile: 00000001
59:14:593 HW\WiimoteReal\IOWin.cpp:708 W[Wiimote]: IOWrite[WWM_WRITE_FILE]: Error on WriteFile: 00000057
59:14:593 HW\WiimoteReal\IOWin.cpp:708 W[Wiimote]: IOWrite[WWM_WRITE_FILE]: Error on WriteFile: 00000057
59:14:593 HW\WiimoteReal\IOWin.cpp:708 W[Wiimote]: IOWrite[WWM_WRITE_FILE]: Error on WriteFile: 00000001

History

#1 Updated by JMC4789 over 3 years ago

Bisect to the exact build where the problem started and I'll get whoever is behind the regression to look at it.

#2 Updated by terence4444 over 3 years ago

Tried a dozen of the builds and found:
5.0-867 OK
5.0-881 NG

#3 Updated by Jasjar over 3 years ago

Try using the hybrid wii remote, you will never have to switch to the emulated wii remote then.

#4 Updated by terence4444 over 3 years ago

Jasjar wrote:

Try using the hybrid wii remote, you will never have to switch to the emulated wii remote then.

Thanks I tried. But in the configuration interface, it does not accept any input from the real Wiimote. I could not set up key mapping of Wiimote part...

#5 Updated by terence4444 over 3 years ago

Update:

I personally solved this problem by buying a compatible USB sensor bar. Cost me only $2. Now everything is fine.

Still I hope this problem could be solved.

#6 Updated by JosJuice almost 3 years ago

  • Milestone set to Current
  • Regression changed from No to Yes
  • Regression start set to 5.0-881

#7 Updated by leoetlino almost 3 years ago

Given that it's a real Wiimote issue, I don't think the bisect makes sense (the version points to a PR of mine that added relative input for emulated remotes).

#8 Updated by leoetlino almost 3 years ago

  • Regression start changed from 5.0-881 to 5.0-876

#9 Updated by Billiard26 over 1 year ago

  • Subject changed from Real Wiimote disconnected when switch controller settings to Real Wiimote connection problems with Toshiba bluetooth stack

#10 Updated by Billiard26 4 months ago

I do have some changes to how Wii remote connections are cleaned up in https://github.com/dolphin-emu/dolphin/pull/8575
Perhaps this solves the problem?

#11 Updated by Billiard26 3 months ago

Will someone please confirm if this issue is present in 5.0-11684 or later?

Also available in: Atom PDF