General

Profile

nodchip

Issues

Activity

12/21/2013

04:52 PM Emulator Emulator Issues #6880 (Won't fix): LLVM JIT in the VertexLoader
I see. I will drop this patch and close this thread. Thank you so much for reviewing my patch.
04:05 PM Emulator Emulator Issues #6880: LLVM JIT in the VertexLoader
wickmarkus86:
Thank you for testing in linux. I'm sorry but I don't have the developing environment for linux and c...
09:06 AM Emulator Emulator Issues #6880: LLVM JIT in the VertexLoader
I cleaned up the code and attached a new patch in this comment. The current performance are:
The Legend of Zelda:...

12/20/2013

07:17 AM Emulator Emulator Issues #6880: LLVM JIT in the VertexLoader
wickmarkus86: It fixed the issue! Thank you so much! I did't understand your comment in #18 and had not been disabl...
06:59 AM Emulator Emulator Issues #6880: LLVM JIT in the VertexLoader
This is a progress report. I'm still investigating the issue that only the USE_LLVM_JIT mode shows garbages on the s...

12/18/2013

08:35 AM Emulator Emulator Issues #6880: LLVM JIT in the VertexLoader
Could you show the fps for each mode? The speed for each mode in my environment was below.
The Legend of Zelda: T...
08:05 AM Emulator Emulator Issues #6880: LLVM JIT in the VertexLoader
> One of the bug for the broken rendering is because we strip the frac from the vertex loader uid: https://code.googl...
05:37 AM Emulator Emulator Issues #6880: LLVM JIT in the VertexLoader
This is a progress report. I attached a new patch file with the following changes.
- Split LLVM modules for each Ve...

12/17/2013

08:42 AM Emulator Emulator Issues #6880: LLVM JIT in the VertexLoader
> Also, random feedback on your code, please do not use std::auto_ptr (BAD). Use C++11 std::unique_ptr instead.
I se...

12/16/2013

02:46 PM Emulator Emulator Issues #6880: LLVM JIT in the VertexLoader
wickmarkus86: It is hard at least for me to write llvm code by hand. I would like to begin with the current way and ...

Also available in: Atom