General

Profile

nwplayer123

  • Registered on: 08/29/2015
  • Last connection: 01/07/2020

Issues

Activity

10/05/2019

12:02 AM Emulator Emulator Issues #11860: Interpreter: bcx bug
It mattered when I was testing in my code, but now that I think about it, that seems logical, must be some compiler/t...

10/01/2019

04:25 AM Emulator Emulator Issues #11869 (New): Riivolution doesn't boot
Searched around, doesn't look like there's already an issue about this. Figured I'd make one in case anyone follows d...

09/29/2019

02:45 AM Emulator Emulator Issues #11868 (New): Memory Breakpoint doesn't catch if Instruction Breakpoint is at same location
I'm attempting to debug Riivolution, set a breakpoint on a sthx, and a memory breakpoint on the region it writes to (...

09/19/2019

08:53 PM Emulator Emulator Issues #11860 (Working as intended): Interpreter: bcx bug
https://github.com/dolphin-emu/dolphin/blob/master/Source/Core/Core/PowerPC/Interpreter/Interpreter_Branch.cpp#L39 sh...

04/24/2019

02:45 AM Emulator Emulator Issues #11314: Qt: Make Layout more compact
Oh man, looked at commits, you've been busy, um.
Couple nitpicks:
* Memory viewer clips (at least on my 4K display)...

03/31/2019

03:42 AM Emulator Emulator Issues #11645: Feature Request: Register Debug Logging
taolas wrote:
> Perhaps a context menu option on the register window that says Log on Break. Maybe a pop out menu fo...

03/28/2019

02:54 PM Emulator Emulator Issues #11645 (New): Feature Request: Register Debug Logging
I don't know how to describe this, basically I want a thing where I can set a breakpoint or smth, and instead of havi...

01/15/2019

02:02 AM Emulator Emulator Issues #11528: Debugger displays wrong bitmask
oh, yeah, I guess that's what I'm thinking of. I'm expecting the where to and not the what. insrwi is just the simpli...
12:52 AM Emulator Emulator Issues #11528: Debugger displays wrong bitmask
Should still be 0x03FF0000, upper halfword is 0x4022, lower halfword is 0x4024, that's how it gets this address, inse...

01/14/2019

03:54 AM Emulator Emulator Issues #11528 (New): Debugger displays wrong bitmask
I've run into an instruction (rlwimi r6, r7, 16, 6, 15) that displays the wrong bitmask, debugger shows it as 0x00000...

Also available in: Atom