Project

General

Profile

Emulator Issues #10025

Dolphin crash when starting games through command line

Added by zigzug over 2 years ago. Updated almost 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Any game

Game ID? (right click the game in the game list, properties, info tab)

N/A

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

N/A

What's the problem? Describe what went wrong.

When loading games through command line, Dolphin immediately crash with the error "*** Caught unhandled unknown exception; terminating".
The error seems to only occur when Real Wii remotes are involved, either configured in the Controller settings or loaded with game-ini profile.

What steps will reproduce the problem?

Loading games commandline with either of these methods:
- dolphin.exe /b /e game.iso
- dolphin.exe /e game.iso

When "Real Wii Remotes" are configured in controller settings (see attachment):
Wii Remote 1: Real Wii Remote
Wii Remote 2: Real Wii Remote

If Wii Remote 1 & 2 are removed the game starts.

However if Real Wii Remotes are loaded in a per game-ini file the error message reappears.

Example of game ini setting for a game.
[Controls]
WiimoteSource0 = 2
WiimoteSource1 = 2

This makes it impossible to load games through command line and using Real Wii Remotes.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

5.0-1699

Also tried 5.0-1420, same error.

What are your PC specifications? (CPU, GPU, Operating System, more)

Reproduced on two systems.

  1. Intel Core i5 6600K, Nvidia GTX 970, Windows 10 2: Intel Core i5-5250U, Intel HD Graphics 6000, Windows 10 (Intel NUC5i5RYH)

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

[Anything else here]

error.jpg (40.7 KB) error.jpg Crash error message zigzug, 01/07/2017 11:13 PM
controller settings.JPG (86.8 KB) controller settings.JPG Controller settings zigzug, 01/07/2017 11:13 PM
5808
5809

Related issues

Is duplicate of Emulator - Emulator Issues #9886: Dolphin crashes when a game launched through the terminal has a game INI that sets WiimoteSourceFixed

History

#2 Updated by zigzug over 2 years ago

With Game ini settings I mean custom files in directory: Dolphin-x64\User\GameSettings*.ini

#3 Updated by zigzug over 2 years ago

Graphics backend DX11 and 12 tested. Same result.

#4 Updated by JosJuice almost 2 years ago

  • Is duplicate of Emulator Issues #9886: Dolphin crashes when a game launched through the terminal has a game INI that sets WiimoteSource added

#5 Updated by JosJuice almost 2 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF