Project

General

Profile

Emulator Issues #11502

MTLCompilerService crash on MacOS using Vulkan

Added by Crosma 4 months ago. Updated 3 months ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
OS X
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem? Describe what went wrong.

On macOS High Sierra, MTLCompilerService crashes during shader compile.

What steps will reproduce the problem?

  1. Choose Vulkan renderer.
  2. Load game.
  3. Shader compiling appears to be very slow, then graphics are rendered without shaders.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

5.0-9211

What are your PC specifications? (CPU, GPU, Operating System, more)

macOS 10.13.6
Intel HD Graphics 6000 1536 MB

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Attached crash report.

History

#1 Updated by Stenzek 3 months ago

  • Status changed from New to Won't fix
  • Operating system OS X added
  • Operating system deleted (N/A)

I believe this is fixed in macOS 10.14. We don't support Vulkan/Metal on macOS 10.13 due to this issue, and others. See https://github.com/dolphin-emu/dolphin/pull/7734

Also available in: Atom PDF