Project

General

Profile

Emulator Issues #11671

Feature Request: Add GameID to Verify tab somewhere

Added by xerxes over 1 year ago. Updated 12 months ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Feature request
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

This would make it slightly more convenient to make sure it's the right ID while checking the MD5 on for example Redump/GameTDB like it used to be using the info pane. I do know it's in the title bar already but it defaults too short to see it for some games, hiding behind an ellipsis.

History

#1 Updated by JosJuice over 1 year ago

Is there a particular reason you need to make sure it's the right ID? If the MD5/SHA-1 exists in the database, you know that the dump hasn't been modified, and that includes the game ID stored in the dump.

#2 Updated by JosJuice over 1 year ago

Or hm, I guess you search for the game in the database by searching for the name or game ID? I normally just search for the MD5 and see if there's a result or not, but I guess that has the problem of not knowing whether getting 0 results means that you have a bad dump or that the hashes for that game just aren't in the database.

#3 Updated by xerxes over 1 year ago

I search by letter in the alphabetical lists on redump for gamecube games. I look at the alphabetical list, then the ID, then find the match, then check the md5 and ID over again to make sure it's a good dump. It's just another thing that I check when I look at the md5, but I didn't think about pasting the md5 into search bars or that the md5 is a better identifier of the game than the ID is anyways. Honestly pasting the md5 is really nice, it pops up directly onto the game's page on redump, so thanks for that tip. I'm not in a massive need for this, it just saves two clicks, it was just something I noticed that I used when confirming dumps.

#4 Updated by JosJuice over 1 year ago

  • Issue type changed from Bug to Feature request
  • Status changed from New to Questionable

#5 Updated by JosJuice 12 months ago

  • Status changed from Questionable to Won't fix

Since we already have the game ID in the info tab and we will have redump integration with https://github.com/dolphin-emu/dolphin/pull/8330, I think I'm going to just close this.

Also available in: Atom PDF