Project

General

Profile

Emulator Issues #9539

Controller issue at Hang Castle level (Sonic Heroes) [Dolphin 4.0-9308]

Added by Accvad over 4 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game: Sonic Heroes

GameID: G9SP8P

MD5: 246bf4d158b65c62c5bc3a0e3f80615d

Description:
I have controller issues at Hang Castle level. I heard that controller issue was fixed by 4.0-8586, but i still having it ONLY at this level.

Reproduction steps:
1)Launch this level
2)Go to the question sign (or find character speak line)
3)Hold any buttom

Dolphin version:
I used 4.0-9308 and 4.0-9175

PC specifications:
I5-2400, Nvidia GTX660 Palit, RAM 8gb, Windows 10 x64

I suppose that this bug is somehow associated with dialogues and sound. Also,


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by JMC4789 over 4 years ago

This is likely only in the PAL version... I remember playing through most of the game and not running into anything odd.

#2 Updated by JMC4789 about 4 years ago

Can you try messing with the Emulated CPU Clock rate in the advanced tab and seeing if you can get it working? I wonder if it's related to some kind of lag in that stage.

#3 Updated by Accvad about 4 years ago

JMC4789 wrote:

Can you try messing with the Emulated CPU Clock rate in the advanced tab and seeing if you can get it working? I wonder if it's related to some kind of lag in that stage.

This bug disappear after setting this clock rate to 125% and above. And of course when i set 80% and below, this bug appears again. Very interesting.

#4 Updated by JMC4789 over 1 year ago

  • Status changed from New to Duplicate

This doesn't happen in single core as far as I could tell. I tested NTSC and PAL version. Marking as a timing issue and merging into the gigantic group.

#5 Updated by JMC4789 over 1 year ago

Also available in: Atom PDF