Project

General

Profile

Emulator Issues #6500

Certain games with Miis glitch faces with Dualcore Enabled

Added by JMC4789 about 7 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Games:

Wii Play - RHAE01
Wii Sports (PAL) - RSPP01

What went wrong?

On Dualcore, the eyes corrupt in these two games. It is unrelated to previous issues about Mii eyes, as EFB2Ram and Texture do not affect them.

http://i.imgur.com/bPKdZxT.png

This is easiest to reproduce in Wii play, because simply going in game at all without a save file will trigger it. With dualcore off, the Miis spawn with proper eyes. This does not seem to affect in game.

This affects all versions of dolphin to my knowledge.

My Computer is a Core i5 3570K with a Geforce GTX 760 and 8GB of ram running Windows 7, 64 bit.

Unfortunately the fifo-log doesn't seem to work with this, because it can only be used in single core.


Related issues

Has duplicate Emulator - Emulator Issues #9108: Wii Sports Resort 'Scoreboard' Mii faces Can Be Glitchy And Bad QualityDuplicate

Has duplicate Emulator - Emulator Issues #10121: Wii Music: Dual Core causes missing Mii headsDuplicate

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by parlane over 6 years ago

  • Status changed from New to New

#2 Updated by kostamarino about 6 years ago

Sync gpu seems to fix them too.

#3 Updated by JMC4789 about 6 years ago

  • Status changed from New to Accepted

#4 Updated by kostamarino almost 6 years ago

Metal Slug Anthology also seems to have this issue with occasional texture corruptions on screen with dual core.

#5 Updated by JMC4789 almost 6 years ago

Nifty, maybe on some of these games we can force dualcore determinism on in the settings?

#6 Updated by JosJuice almost 5 years ago

  • Has duplicate Emulator Issues #9108: Wii Sports Resort 'Scoreboard' Mii faces Can Be Glitchy And Bad Quality added

#7 Updated by JosJuice over 3 years ago

#8 Updated by JMC4789 about 3 years ago

  • Status changed from Accepted to Duplicate

dualcore sucks at everything.

#9 Updated by JMC4789 about 3 years ago

Also available in: Atom PDF