Project

General

Profile

Emulator Issues #6547

Auto adjust Window Size doesn't activate properly

Added by school.player over 7 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

READ THIS: https://forums.dolphin-emu.org/showthread.php?pid=276132 <<<
Your answers are here!

Game Name?
N/A

Game ID?
N/A

What went wrong?
If you start a game with Auto adjust Window Size enabled, it only takes effect once you open the Graphics configuration window.

What did you expect to happen instead?
The game window automatically resizes when the game starts.

What steps will reproduce the problem?
[Don't assume we have played the game and know its level names. Be as
detailed as possible.]
1. Enable Auto adjust Window Size
2. For effect, change IR to be very different from the window's current size
3. Start a game
4. (optional) Open Graphics tab

Dolphin 3.5 and Dolphin 3.5-367 are old versions of Dolphin that have
known issues and bugs. Have you tested with the latest version from
http://dolphin-emu.org/download ?
Yes

Which versions of Dolphin did you test on?
~3.5-367 to present

Which version of Dolphin used to work?
Unknown

What are your PC specifications (example: Operating System, CPU and GPU)?
Windows 7 Home Premium
Core i3 540 @ 3.06GHz
4GB RAM
AMD Radeon HD 7770 w/ latest stable drivers

64 or 32 bit Operating System?
64-bit

64 or 32 bit Dolphin?
64-bit

Any other relevant information (e.g. logs, screenshots, configuration
files)
[Upload big files to a hosting service and post links here!]

Do *not attach files to this issue. Upload them to another site and
link here. Use imgur.com for images and pastie.org for logs.
*

History

#1 Updated by rachelbryk over 7 years ago

Works fine for me.

#2 Updated by JMC4789 over 7 years ago

Works fine for me

#3 Updated by MayImilae over 7 years ago

  • Status changed from New to Questionable

Two people commented on this and no one tagged it as questionable? Pfft lazy.

And while I'm here, works for me :P. Specify the game please and your settings, you didn't give much.

#4 Updated by MayImilae over 7 years ago

And give your EXACT Dolphin revision please. No dodging.

#5 Updated by JMC4789 over 7 years ago

Oh duh; games with certain options have this happen. It happens if Sonic Heroes. Some games force 1X IR, which makes it so opening the graphics menu overrides that.

#6 Updated by school.player over 7 years ago

http://www.youtube.com/watch?v=a7lWDGYnP90
That's with the netplay rev I had on hand, but it hasn't changed.

#7 Updated by MayImilae over 7 years ago

Lots of problems here. You didn't use the latest master build in the video, no matter what you have "handy". Don't used an old version of a branch for error reporting. You used D3D9, which is depreciated. You used render to main window, a pretty big freakin detail. All of that stuff you should have said in the initial report, or after I nagged you the first time. Bah. Oh, and you made the dialup user load a video to find information I asked you for and that you could have given in no time with text. I hate you now.

Well, tested D3D9 with render to main window in Melee. Perfectly fine. I have no idea why you have this problem, but no one else can reproduce it.

#8 Updated by JMC4789 over 7 years ago

  • Status changed from Questionable to Won't fix

This is invalid/wontfix, and, it's actually an issue I ran into for different reasons a while ago.

Basically, Melee's INI file sets scaled EFB to the nearest multiple of screensize. 1.5x becomes 1, 2 stays 2, 2.5x becomes 2, etc. This is done because a lot of the shadow/reflection maps glitch out if you're not using an exact EFB scale up from 1X.

If you want to change this, you can edit melee's INI, but you may experience graphical bugs if you do that. Because the emulator is doing nothing wrong, I'm going to mark this as won't fix, at least for now. Before I complained about it always setting to 1x, scaled EFB didn't work at all until you opened the graphics menu!

#9 Updated by school.player over 7 years ago

Sorry I didn't test more, it was pretty late when I posted the video.

I was planning on showing other games, backends, not rendering to main, etc.

#10 Updated by JMC4789 over 7 years ago

It's fine, there should be some place to note an issue like this. Perhaps it'll be added to the wiki so that in the future people who see this happening can find a solution without thinking it's a glitch. I do believe that it was a strange behavior and should be explained somewhere.

Also available in: Atom PDF