Project

General

Profile

Emulator Issues #6728

GameCube Peripherals (VBAM, Bongos, etc) are unsupported in Netplay

Added by velocity7 almost 6 years ago.

Status:
Accepted
Priority:
Normal
Assignee:
Category:
Netplay
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Any game with Joybus, such as Four Swords Adventures.

Game ID?

Any game with Joybus, such as Four Swords Adventures (G4SE01).

What went wrong?

VBA-M cannot connect to Dolphin via Joybus when NetPlay is initiated.

What did you expect to happen instead?

Should connect to Dolphin.

What steps will reproduce the problem?

  1. Host a NetPlay session on one computer, with GBA set to port 1 on Gamecube (more if other computers are connecting). Select Four Swords Adventures, as an example.
  2. Start game, whether another computer has connected to host or not.
  3. Attempt to start VBA-M to connect on the host. Instead it gets stuck at the Game Boy Advance BIOS screen.

Dolphin 3.5 and Dolphin 3.5-367 are old versions of Dolphin that have
known issues and bugs. Have you tested with the latest version from

http://dolphin-emu.org/download ?

Yes

Which versions of Dolphin did you test on?

4.0-206

Which version of Dolphin used to work?

N/A

What are your PC specifications (example: Operating System, CPU and GPU)?

Windows 7 x64 Ultimate
Intel Core i7-2600K @ 4.4 GHz
16 GB Kingston RAM
GeForce GTX 670 2GB
64-bit Dolphin


Related issues

Blocks Emulator - Emulator Issues #7098: GBA Connectivity Master IssueAccepted

History

#1 Updated by MayImilae almost 6 years ago

  • Category set to netplay

#2 Updated by JMC4789 almost 6 years ago

  • Status changed from New to Accepted

Netplay does not currently support anything outside of GameCube Controllers and Wiimotes + peripherals.

That means Four Swords Adventures cannot be played on netplay.

Bongos is probably fixable, as it was supported before.

This is either "wontfix" or priority low. If anyone wants to counter me and say it's completely impossible, they will.

Also available in: Atom PDF