Project

General

Profile

Emulator Issues #9038

Heavy Fire Black Arms not working.

Added by Robercik over 5 years ago. Updated about 1 month ago.

Status:
Accepted
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Heavy Fire Black Arms

Game ID? (right click the game in the game list, properties, info tab)

WHYETY

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

...

What's the problem? Describe what went wrong.

The game freezes on the screen , informing about using the Zapper, showing a large number of FPS , and low VPS. http://iv.pl/images/34212657254532301196.png

What steps will reproduce the problem?

  1. Run game.
  2. Finish

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

4.0.2. I tested also 4.0-7941

What are your PC specifications? (CPU, GPU, Operating System, more)

Inter HD Graphics
Intercore i3 CPU M 370
3 GB Ram
Windows 7 64x

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

http://iv.pl/images/12679507194823994756.png
http://iv.pl/images/19387757333866731936.png
http://iv.pl/images/41857300899229685208.png
http://iv.pl/images/31676589825427401249.png
http://iv.pl/images/60576621950575630700.png
http://iv.pl/images/24589516147810121797.png

History

#1 Updated by JMC4789 over 2 years ago

  • Status changed from New to Accepted

This is another of those games that needs more exact timings. I don't know if I have a GPU timing issue.

I'll make a global issue to merge all of them together when I get some time.

#2 Updated by ZephyrSurfer 4 months ago

Game does boot up and run. User needs to press A on the zapper selection screen.

#3 Updated by wertercatt about 1 month ago

ZephyrSurfer wrote:

Game does boot up and run. User needs to press A on the zapper selection screen.

I can confirm in testing on 5.0-14002. (Windows 10, D3D12, GTX 750 Ti, Ryzen 5 1600.)

The Wiimote Zapper screen runs abjectly terrible at about 1FPS, but spamming the A button will eventually get past it. The game works fine otherwise.

#4 Updated by ZephyrSurfer about 1 month ago

So I tried this in single core instead, dual core seems to run reasonably. In single core the game loads incredibly slowly instead.

In dolphin a screen appears stating "WAIT SOLDIER" before main menu and a different "WAIT SOLDIER" screen appears after selecting "PLAY GAME" but before the first level loads and holds for a long time. Neither of these loading screens appear on a real console, it loads instantly there.

I tracked down a revision which slowed down loads considerably.

The revision which has some effect in slowing down this title further is 4.0-9154(https://dolphin-emu.org/download/dev/8f74f1f4e9aa1e045187b994631aa4476cbb745e/). This might help figure out area to look at.

Also available in: Atom PDF