Project

General

Profile

Emulator Issues #9882

Vulkan texture issues with Beach Spikers, possibly FPRF emulation related

Added by kostamarino about 3 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

[Put Game Name here]
Beach Spikers

Game ID? (right click the game in the game list, properties, info tab)

[Put Game ID here]
GBSE8P

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

[Put MD5 Hash here]
c18f2fae7fc17adfea6656213c76e097
Compressed

What's the problem? Describe what went wrong.

[Description here]
Textures are messed up in a similar manner to what other backends show if you disable fprf emulation in game properties.

What steps will reproduce the problem?

[Reproduction steps here]
Just boot the game and watch the intro sequence. The field textures will be dark.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

[Versions here]
5.0 - 1259

What are your PC specifications? (CPU, GPU, Operating System, more)

[PC specs here]
i5 2500k, 960 gtx, windows 10 x64

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

[Anything else here]
http://prntscr.com/d4rkt9


Related issues

Is duplicate of Emulator - Emulator Issues #9957: Vulkan: Gecko OS screen renders incorrectlyNew

History

#1 Updated by JMC4789 about 3 years ago

Since fprf is a CPU emulation option... this title makes absolutely no sense.

#2 Updated by JMC4789 about 3 years ago

Something else is probably wrong with Vulkan though, or there could be GPU driver issues.

#3 Updated by kostamarino about 3 years ago

JMC4789 wrote:

Since fprf is a CPU emulation option... this title makes absolutely no sense.

Yet it affects only the vulkan backend, opengl, d3d11, d3d12 are fine. And fprf emulation affects the textures in this game.

#4 Updated by JMC4789 about 3 years ago

I'm just saying, the reference to FPRF most likely is just going to mislead any graphics dev that goes to look into it. It doesn't make sense to be related to FPRF and then per back-end.

Except to maybe degasus, who has worked in both graphics and CPU.

#5 Updated by Stenzek over 2 years ago

  • Status changed from New to Duplicate

NVIDIA depth issue.

#6 Updated by Stenzek over 2 years ago

Also available in: Atom PDF