Project

General

Profile

Emulator Issues #10234

Bolt video game can't find save files to load

Added by holmez000 over 2 years ago. Updated 5 months ago.

Status:
Work started
Priority:
High
Assignee:
% Done:

20%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Bolt

Game ID? (right click the game in the game list, properties, info tab)

[RLUE4Q]

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

[58d4dc03ff2b16e9d1ce196d84194937]

What's the problem? Describe what went wrong.

[when i try to load my saved game file i get this error msg. (there are no valid saved games in wii system memory )]

What steps will reproduce the problem?

[i start the game and when it gets New game - load game , i choose new game then it gives me 3 empty slots to save game so i chooses first empty slot and then i played the game and finished many save points and next day when i tried to play the game i choose load game then when it tried to load it get that error there is no save files, even i try to start i new game it didn't give me the 3 empty slots , it gives me nothing just the courser so forced to close the game and delete the save files from wii folder ]

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

[5.0]

What are your PC specifications? (CPU, GPU, Operating System, more)

[AMD FX 6100, nVidia geforce gt630, win7 64bit ultimate, 8 GB ram]

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

[Anything else here]

History

#1 Updated by JMC4789 over 2 years ago

Can you get any logs from when it's saving or trying to load a save?

#2 Updated by JMC4789 over 2 years ago

I'll order the game and test it myself. I realize that 4 months to respond was probably a bit too long to maintain your interest lol.

#3 Updated by JMC4789 over 2 years ago

  • Status changed from New to Work started
  • Assignee set to JMC4789

Ordered

#4 Updated by JMC4789 about 2 years ago

  • Status changed from Work started to Accepted
  • Assignee changed from JMC4789 to leoetlino

Could this begin a new chapter of the trio of destruction?

Save is definitely there but, the game malfunctions when it tries to load it.

#5 Updated by leoetlino about 2 years ago

  • Priority changed from Normal to High

IOS bug. The order of files returned by FS_ReadDir appears to be wrong. In Dolphin, it's sorted alphabetically... which doesn't really make sense.

I haven't yet determined what IOS actually does to determine the order, but it's likely to depend on the order in which files were created.

This can cause issues that range from not being able to find save files, to opening and writing to/deleting the wrong file (depending on how many assumptions a title makes).

#6 Updated by leoetlino over 1 year ago

  • Status changed from Accepted to Work started

Confirmed to be a FS bug. Also confirmed to be fixed without ugly workarounds simply by keeping track of filesystem metadata properly (in a WIP nand-image branch).

#7 Updated by leoetlino over 1 year ago

  • % Done changed from 0 to 20

Now that the new filesystem interface has been merged, we now need to use it every time the FS is accessed in order to be able to track metadata properly. The following will need to be migrated:

#8 Updated by flacs 7 months ago

Can't reproduce this issue anymore. EDIT: Nevermind, I'm just bad at reading how to reproduce it.

#9 Updated by Miksel12 5 months ago

This video shows Bolt in-game on 5.0-8909: https://www.youtube.com/watch?v=0FAAHdf424I

#10 Updated by JosJuice 5 months ago

This issue is not about not being able to go in-game at all, it's about not being able to go in-game when there is existing save data.

#11 Updated by Miksel12 5 months ago

I should read better next time...

Also available in: Atom PDF